Outlook 2016 Account Add Problem

Ran into a problem today adding an Exchange account to an Outlook 2016 installation

It seems Microsoft has removed most of the advanced settings as a result of the removal of MAPI support from Outlook, but what it means is that your Autodiscover – MUST work.

For lab environments, we don’t always setup Autodiscover, we just manually setup the accounts.    I figured I would add an SRV record to fix it, so I did.   However I had another problem.

Microsoft has a great tool called the Remote Connectivity Analyzer, which tests and tells you when it finds problems with connectivity – well – I passed most of them.  Yes there were a few errors, as AutoDiscover has a few methods.

The mail settings panel would get “stuck” at this screen.   It would search forever.  Searching for your mail server settings stuck at searching for settings.

mailproblem

This is caused by the mail settings trying to auto discover using this URL

https://testdomain.com:443/Autodiscover/Autodiscover.xml

In my environment (and many others) this doesn’t exist.  We have a mail server running on mail.domain.com or owa.domain.com  – the root domain doesn’t have this.    However unless Mail settings get’s a 404, 500 or another HTTP error, it will try 20+ times to connect, each with a VERY long 30 second timeout.   – that means 15-20 minutes of trying before it will give up.    Much longer than any users (And me in particular) is ever willing to wait.

Solution?    Registry edit.

[HKEY_CURRENT_USER\software\policies\microsoft\office\16.0\outlook\autodiscover] “excludehttpsrootdomain”=dword:00000001

That’s it,  it tells Outlook to skip that step, and move on to other AutoDiscover methods.

A simple solution, which google didn’t immediately find me, I did find it buried in a few conversations on Reddit – but hopefully this post, will give it better goggleability.

Hopefully AutoDiscover Outlook 2016 and future versions will be come a little less problematic, a little less trouble, and not as slow.

 

 

 

Advertisements

8 thoughts on “Outlook 2016 Account Add Problem

  1. in my registry, I can only find [HKEY_CURRENT_USER\software\microsoft\office\16.0\outlook\autodiscover without going through policies, but don’t know how to continue

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s